Authentication Service Maintenance - SSO Infrastructure Update

Incident Report for Firebolt

Resolved

The scheduled maintenance related to the SSO domain update has been successfully completed.

All authentication and sign-in services are now fully operational, and no further interruptions are expected.

Thank you for your patience during this maintenance window.
Posted Oct 23, 2025 - 08:58 UTC

Identified

We are performing a scheduled maintenance as part of our ongoing improvements to authentication and service account infrastructure.

During this time, users may experience temporary login or registration interruptions (timeouts or brief sign-in errors).

No action is required, and service account authentication will remain unaffected.
Once the update is complete, all systems will resume normal operation.
Posted Oct 23, 2025 - 07:00 UTC
This incident affected: Firebolt Components (Web Application, Tenant Account Creation).